Remote Desktop Connection (mstsc) using 4K screen

Problem
If you have a 4K screen monitor/laptop and you are using Remote Desktop Connection (RDC), most probably the remote screen resolution is too high and the items/text awfully small.

Solution
First, I tried to install Remote Desktop Manager, and having checked the option RDCMan.exe -> Properties -> Compatibility -> “Override high DPI scalling behaviour” but didn’t worked.
4k-rdc-3

After that, I’ve made the following changes:

    Go to Remote Desktop Connection (mstsc.exe). Click on “Show Option” -> Display and set a custom resolution eg. 1280×768. Now connect to the remote computer.
    4k-rdc-1
    After you are connected to the remote computer, click on the top icon of the remote desktop connection app and select a zoom like 200% – 250%.
    4k-rdc-2

I hope that this info will be useful!

Leave a Reply